On-dark Ancestry logo
Customers may be experiencing issues at this time. Investigation underway.
Incident Report for Site Availability
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 19:18 MDT
Update
We are continuing to investigate this issue.
Posted Aug 10, 2022 - 19:08 MDT
Update
We are continuing to investigate this issue.
Posted Aug 10, 2022 - 16:26 MDT
Investigating
The cause for site impact is being investigated at this time.
Posted Aug 10, 2022 - 16:23 MDT
This incident affected: Login Processes, DNA-related Features, and Shopping Cart.