On-dark Ancestry logo

Customers may be experiencing issues at this time. Investigation underway.

Incident Report for Site Availability

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 10:09 MDT

Investigating

The cause for site impact is being investigated at this time. Additional information and status will be provided as available.
Posted Jun 15, 2026 - 09:15 MDT
This incident affected: Family Tree Features.